Atlantis 2 Burnt rubber taste

I purchased an Atlantis 2 tank for use with an IPV2 Box mod and for the first month it was great. I recently opened a new box of replacement coils and I put the first head in, primed it and soaked it as i had done with the previous boxes worth of head changes. Im getting this burnt rubber taste (not burning of cotton). So i changed to another head and resoaked primed and tried again and the same ended up going through the whole box with no change. I cleaned the whole tank between changes. Any suggestions would be appreciated.
Comments
  • 6 Comments sorted by Votes Date Added
  • Dear customer,
    Thanks for supporting aspire and sorry for the inconvenience.
    What's the resistance of the coil you use with the atlantis 2?
    At what wattage did you use?
    What's the PG:VG proportion of your juice?

    After refilling, customer need let the tank sit for a while, to allow the coil to soak up the liquid, some people add some liquid to the coil before installing. After it sits for a little bit, you should take a few pulls, or dry hits.
    What you do is take a hit, but do not press the battery button. This pulls the liquid into the coil.

    What's more,please refilling the tank in time before the e-juice inside the tank completely used up to avoid burn taste.
    Every refilling,customer need let the device stand up for 3-5 minutes.
    For a new coil,the first few puffs,the flavor is not pure,it is normal,just let the device stand up for more times,after the first few puffs,the flavor will go pure and pure.

    Best regards,
    Fenny
  • i just got my atlantis 2 today and i am getting the same burnt rubber taste. The coil is wicked and i also even flooded it but no matter what i am still getting that burnt rubber taste. I even changed coils and still getting the same results. Further inspection revealed that its the insulator is whats burning. Are the insulators not high heat resistant?
  • If you are burning the insulating rings, you need to lower your voltage/wattage. Or cut back on chain vaping ;)
  • To fully answer your question, what is the device you are running the tank on? Also, where is the insulator being burnt at? I am curious if there is a hot spot in the coil that is causing more power to go to the leads of the coil than the coil itself. It is common to have when a part of the coil is wrapped and a spot on it is shorted by another wire section of the coil. If that is the case, the electricity going through the lead on the coil may heat up and could possibly burn the insulator. Aspire does use a high heat resistant insulator. I would recommend trying a different coil. Also check the resistance of the coil itself with an OHM meter. If you do not have one, a local vape shop should have one on hand. If the coil has a much lower resistance than what it is rated for then this is probably what is happening.
  • I get the same taste also but usally goes away after a couple days use what I have found out is most v2 coils take a little bit longer to Break in then most other coils
© 2017 Powered by Aspire