What's wrong with my CF sub ohm battery?

This Jack Fitzpatrick,so i bought one of your CF Sub Ohm Battery a couple of weeks ago
and its been working perfect no problem. until like either yesterday or the day before when i picked it up after it fell a short distance of like maybe 1ft off of my bed and i didn't think anything of it. so when i went to go use it...it wasn't working
it still lit up when i pressed the button, locks when i press it 5 times and seems to be able to charge..but no vapor comes out.
i have been talking with another person that works with you guys, laurie, and have been sending her messages about this problem. and she said to send the security code to make sure its authentic, and i did the number is 44733 58439 56097 520121.
Comments
  • 2 Comments sorted by Votes Date Added
  • Dear Jack,

    I am sorry to hear that.
    From your description"it still lit up when i pressed the button, locks when i press it 5 times and seems to be able to charge..but no vapor comes out."
    we think the tank was not make good connection with the battery.

    If you use the correct tank,please reassemble the coil to the base hardware,make sure the coil must screw to the base hardware tightly to press the connection pin pop out to make good connection with the battery.

    If still not work,please change another coil to have a try,make sure the coil must screw to the base hardware tightly to press the connection pin pop out to make good connection with the battery.
    What's more,for a new coil,after assembling,please let the tank stand up for 3-5 minutes to let the coil soak up enough e-juice before using.

    Best Regards!
© 2017 Powered by Aspire