Aspire Atlantis Positve Pin Issue

I have an Atlantis which I’ve used without issue for about a month and after replacing one of the coil heads and reattaching to my Vapor Flask (DNA40), any mech mod, Hana Modz V3 DNA40 the positive post seems to retract into the deck when its screwed on. I’ve tried softly tightening the atomizer onto the 510 deck so it wouldn’t be pushed up into the bottom deck and would be able to pass along the + voltage. Is there a solution for this?
Comments
  • 2 Comments sorted by Votes Date Added
  • Dear Customer,
    Thank you for supporting aspire.
    Please make sure the coil was screwed to the base hardware tightly to press the connector pin under the base hardware pop out to make good connection with the battery.
    If the connector pin was stuck into the deck,users can use a tiny tool to press the connector pin pop out.

    If still not work,we think the connector pin and insulator ring need be replaced.
    Customers can just buy the connector pin and insulator ring from our online store,
    Here is the link:
    https://online.aspirecig.com/aspire-atla ... -p-94.html
    As the connector pin and insulator ring are consumables,customers can stock some for replacement.

    Have a nice day!
© 2017 Powered by Aspire