Atlantis Issues

First, I should start out by saying that I am not a new vaper by any means. So when I go on to my story believe 100% that I did exactly what I was supposed to do with this tank prior to lighting it off.

Anyway, here is my issue:
I bought my second Atlantis tank about 2 weeks ago after losing my first, which was heartbreaking lol. The first tank I had I was using for about a month and used anything from 50/50 to MAX VG and each and EVERY time this tank performed like a superstar with ZERO issues. Since I have bought this second one my life has been hell. The issue that I am having is that all of my coils are continuously getting destroyed when I use them in this tank. They don't last longer than 3-4 days tops without eventually burning (luckily I bought a crap ton of replacement coils). Here is what happens from brand new to burnt...

I take coil out of pouch and saturate it with whatever liquid I am using. I will drip on all of the feed ports on the side until it is absorbed and then I will do a ring of liquid on the mesh and wait until I see it has absorbed fully. Once both of those are completed I install the coil into the tank and put it all together. Once everything is nice and snug, but not too tight, that is when I begin to prime the hell out of the coil. I generally just slowly inhale for about 10-15 seconds about 2-3 times with my thumb over the air hole. Once I finish that I let it sit for about 5-10 minutes and then do one more priming hit. Next I will turn my mod down to 20W to start it out light and slowly work my way up to 30W when I feel that the wick is going perfectly. This is where things go downhill. Once I get to 30 it will work perfectly for about half a day and the next I will notice a considerable difference in the size of the hit. From there on the quality of the hit just continues to decline until I eventually get that one, nasty, vomit inducing dry burn. I can't for the life of me figure out what is going on with this thing. When I first noticed it I was using MAX VG, then I changed to 80VG/20PG, and finally I used 50/50. The 50/50 seemed to work very well but only delayed the issue I am having.

2 other symptoms I am seeing are:

1. Once I begin to get a decline in hit quality and before I get a dry hit, I check the coil and i have noticed that every single coil is turning black with gunk/burnt crap right in the center of the wick. The top and bottom are brand new looking but right in the middle looks like a smokers lung.

2. The base of the tank appears to be getting entirely too warm to be functioning normally. This leads me to believe that something in the base that involves the power contact is not working correctly and is potentially destroying my coils.

The main reason I am posting this is to see if anyone else has had this issue before. I spoke to my shop and after a few days of troubleshooting this thing we both agree it has to be something in the tank itself and I am going to get a free one, however, I cant find anything online that supports this theory. I am really hoping someone has experienced this before and has an answer before I get my regular vape shop to hand out a free $50 piece of gear to me. Just doesn't seem right to hold them responsible.

Any ideas?
Comments
  • 8 Comments sorted by Votes Date Added
  • Dear Customer,
    Thank you for supporting aspire and sorry to hear that.
    The coils are the consumables, the use frequency, battery wattage, the PG:VG proportion of e-liquid all can impact the coils' life.
    High vg e-juice and high wattage means larger vapor,but at the same time,it will also short the coils life.
    What's more,high sugar/sweetener content e-juice will also affect the coils life. if it has a high sugar/sweetener content it will gunk up and carmalize on the coil really fast. The darkening of the juice is the caramelized coils coloring it.if leave it out much in the heat or the sun it will darken a little as well depending on the nicotine content.
    In order to avoid the burn problem:please refilling the tank in time before the e-juice inside the tank completely used up to avoid burn taste.Every refilling,please let the device stand up for 3-5 minutes.
    In order to get long life,if the maxi wattage output of the battery is 30W,we suggest use our product at wattage 20W-25W.We don't suggest customer to use our product with high wattage output battery,like the maxi wattage output can reach to 50W/100w/150W.

    Have a nice day!
  • I have started having the same issues as the original poster in this thread. I got my Atlantis in November 2014 and it worked very well until about 4 weeks ago towards the end of February 2015.

    I am doing everything the same as I was back when I bought the tank but out of nowhere everything started failing like the original post described. I am getting scorching hot hits and very little vapor production. My coils have been lasting at most a half day and many of them I tried have been burning immediately on the first tank fill up. I have used the old coils and the newer all cotton coils and nothing is working. All of the tips given by Tina in this thread have been of no use to me. It doesn't seem like there is anything I can do.

    Where can I go from here? Like the OP, I haven't really seen anything anywhere on the internet about this. Very frustrating. My friend who know a lot about vaping is even stumped by this.
  • Dear Customer,
    Thank you for supporting aspire and sorry for the inconvenience!
    What kind of battery did you use?What wattage did you use?What is the vg proportion did you use?
    Because the vape heating is very large,for sometime using,the vapor will get warm,so,we suggest customers to take a few puffs,then let the tank have a rest.

    Have a nice day!
  • I am starting to think the issue may be my batteries, but I am still not sure. I am using two batteries, they are:

    Sony VTC4 18650 2100mAh
    Efest IMR 18650 LiMn 2500mAh

    I am using the Trustfire Multifunctional battery charger

    I have a Sigelei 30W mini box

    I usually run my Atlantis at 20W-22W

    I have used juices ranging from 70%VG to 50%VG and have issues with all of them.

    Taking a break doesn't stop the problem. Even on the first hit after a break the loud crackling and popping is there that shoots juice all over and gives a hot and nasty hit that hurts the throat. I have this issue with my Atlantis and yesterday I tried my friends Kanger Subtank for a day and eventually had the same issue which leads me to believe that the issue is no longer with my Atlantis. I am going on vacation next week but I think ordering some new batteries and a new charger is the next step.

    This issue came on slowly over the course of a few weeks which makes me think something slowly started to fail. Could it be that my battery charger is defective, both of my batteries are defective, or my charger has essentially fried my batteries while charging? I will update this post once I receive my batteries. Let me know what you think.
  • I have new batteries and a new charger and I am having the same issues as before. I have followed all of the guidelines in this thread and nothing works. I have no idea where to go from here.

    I am using an Aspire Atlantis and a Kanger Subtank on 2 different Sigelei mods that can fire down to .5 ohms. Both tanks are burning and harsh on both mods. What could this possibly be? I am so frustrated. My Atlantis worked for months perfectly until this started and now I'm having the issue with a completely different set up.
  • Just thought I would let you guys know that the issue was not with my tanks or mods. It looks like my batteries were getting overcharged in my charger. I got some new batteries, a new charger, and some really nice juice and my Atlantis has been working as well as the day I got it. I left my batteries on the charger overnight sometimes which is a bad idea. Now I watch is closely and don't let them sit on the charger past when they are finished charging. Live and learn.
  • Dear Customer,
    The coils are the consumables, the use frequency, battery voltage, the PG:VG proportion of e-liquid all can impact the coils' life.
    High wattage and high vg proportion e-juice means large vapor,but at the same time,it will short the coils' life.
    Many users use the product without reading our manual, the coils are not screw into the hardware tightly, it will burn out quickly.
    After refilling,customer need let the tank sit for awhile, to allow the coil to soak up the liquid, some people add some liquid to the coil before installing. After it sits for a little bit, you should take a few pulls, or dry hits.
    What you do is take a hit, but do not press the battery button. This pulls the liquid into the coil.
    High proportion of VG e-juice or high sugar/sweetener/nicotine content e-juice will also affect the coils life,if the e-juice has a high sugar/sweetener content it will gunk up and carmalize on the coil really fast. The darkening of the juice is the caramelized coils coloring it and short the coils' life.

    What's more,please refilling the tank in time before the e-juice inside the tank completely used up to avoid burn taste.
    Every refilling,customer need let the device stand up for 3-5 minutes.
    For a new coil,the first few puffs,the flavor is not pure,it is normal,just let the device stand up for more times,after the first few puffs,the flavor will go pure and pure.

    Our Atlantis is compatible with 20-30W wattage output batteries,Customers need check the wattage output is enough to fire our Atlantis,what's more,please make sure using wattage not exceed 30W,or you will burn the coils.But if customers use high wattage output battery(the maximum output wattage can reach to 50W/100W/150W..),we suggest customers to use the lowest wattage to fire the tank,if 18W can fire the tank ,please use 18 W.

    Have a nice day!
© 2017 Powered by Aspire