Atlantis coils

I tried to submit this before but I guess it got lost in the ether, oh well. I'm trying to find out why I'm getting a horrible burnt flavor with my Atlantis. I'm using a Tesla Penny mech mod with an Atlantis for a little less than a month with no problems. Then I get to my third coil and it tastes horrible. I primed it, soaked the coil in e-liquid, I let it sit, etc. Still no dice. This all started with the 5ml replacement tank. When I received it I changed the coil and ever since - burnt flavor :(. Any ideas?
Comments
  • 2 Comments sorted by Votes Date Added
  • Dear Customer,
    Thank you for supporting aspire!
    For a new coil,the first few puffs,the flavor is not pure,it is normal,just let the device stand up for more times,after the first few puffs,the flavor will go pure and pure.If the flavor is still not pure.
    Please try to disassemble the device,wash it with clean water,then let it air dry for 1-2 days.
    Then change out the old coils.
    Notice,the coil can not be washed by water.
    What's more,please make sure the wattage is not exceed the permissible range 30W,if once,the coil will be damaged,no matter how low wattage used later.For high wattage output battery,we suggest to use our product at low wattage like 20w.

    Have a nice day!
© 2017 Powered by Aspire