Atlantis - burnt taste

Hello all, I want to preface this by saying that this is the first time I've had a problem with an Aspire product. I bought an Atlantis a little less than a month ago and have had NO problems with it - performed beautifully. Then, I go to switch the coil out. I put maybe .5ml in the coil itself, let the coil sit in the tank (with juice in it) over night, and did a few primer puffs. What do you know - that stupid burnt taste is there. And now it won't leave. All the juice holes are uncovered (although I know there's debate about whether they should be covered by the little tabs or uncovered). I can see the bubbles come up indicating that juice is getting to the coil. The first few hits are OK and then it seems like the juice I placed directly on the coil gets used up and no new juice is getting to the coils - at least that is what it tastes like. At this point I have a new coil literally soaking in a shot glass of e-juice, hoping that it will fix the issue. I've tried everything I can think of beyond literally poking a hole in the cotton of the juice hole, but I'm worried I'll flood it out if I do that. Any ideas?
Comments
  • 2 Comments sorted by Votes Date Added
  • Dear Customer,
    Thank you for supporting aspire and sorry to hear that!
    For a new coil,the first few puffs,the flavor is not pure,it is normal,just let the device stand up for more times,after the first few puffs,the flavor will go pure and pure.If the taste is still not pure.
    We suggest to disassemble the device and wash it with clean water,then let it air dry for 1-2 days.
    Then change out the old coils.
    Notice,the coil can not be washed by water.
    We don't suggest customer to leave the e-juice in the tank over night,for the airflow hole on the coil is very larger,which will make the coil soak up many e-juice,when first using,the heat is not enough,the spitting or e-juice be soak into mouth problem will happen.

    Have a nice day!
  • Kevin, I am experiencing this same issue. I've went through 4 replaceable coils and still no luck. Have you found a solution? I've literally tried everything I can think of. Thanks in advance.
© 2017 Powered by Aspire