Atlantis Tank (Glass not removing, flavor stuck.)

My Atlantis tank's glass is NOT budging. It does NOT wiggle loose like the video provided by Aspire shows. It doesn't move at ALL. It's absolutely stuck.

I'd like to replace the glass and thoroughly clean the unit after getting a menthol flavor stuck that simply won't come out even after replacing the coil. I only have one fresh coil left after this one so I can't afford to keep trying new coils at the moment.

Please help. It's never been dropped or broken or anything. It's brand new. I've had it maybe a month.
Comments
  • 7 Comments sorted by Votes Date Added
  • Try spinning the tank a little bit instead of wiggling it, or a bit of both.
  • Did try that. It won't turn or wiggle or budge even a speck.
  • Damn, I know these things have tight tolerances but that's excessive. Do you still have the spare tank that Aspire included in the Atlantis packaging? Might have to break out the old one...
  • Yeah, but I was hoping it was just a fluke. Actually my boyfriend has a completely separate Atlantis tank of his own, so just to make sure it wasn't just my device specifically I went to try and see if I could remove that one - maybe shelve mine and use his - to no avail either. It too was seemingly unwavering by nature. Didn't move a budge.

    Have tried sturdy cloths, dry hands, running under cold/hot water, etc. On both devices it's jammed. And both are authentic brand new devices.

    Luckily I just ordered a 5ml replacement tank for it anyways, so once that part comes my problem should be solved. But in the meantime this flavor is stuck and makes me sick to my stomach.
  • Same issue here on my Mini nautilus....after only a few days use...

    Help!
  • I did have an issue with a particular flavor that impregnated all the gaskets, and ruined any other flavor that I put in the Atlantis.

    How I got rid of it:
    1. Throw away the coil. I experimented trying to clean the coil out, again. Nothing worked.
    2. Dissemble the tank completely. Being VERY, VERY careful with removing the glass tank. As I broke it trying to remove it.
    3. Make a water and baking soda solution. Roughly a half cup of water of hot water, and a teaspoon or two of baking soda. Make sure the baking soda is completely dissolved in the water (none is sitting on the bottom of the glass).
    4. Put the Atlantis parts in the baking soda water solution over night.
    5. Rinse off the parts in the morning. You might having some tarnishing on the nickel plated chimney. It can be buffed cleaned.
    6. Put the upper assembly and the lower gasket in the sun for a day, or two. (This removed most of the smell of the old juice).
    7. Find an ultrasonic cleaner (My local vape shop has one that they use to clean other peoples setups. If not you might have to purchase one).
    8. Use +90% isopropyl alcohol in the ultrasonic cleaner. Run a couple of cycles.
    9. Rinse, and rinse, and rinse the parts to get rid of the isopropyl alcohol.
    10. Reassemble the tank and use a new coil.

    11. Last but not least, IF the juice was the problem, don't use that flavor anymore.

    The gaskets are food grade rated silicone, so that is not the issue. The issue is certain acidic juices. The same thing happens with silicone cooking utensils (Myself and Aspire gathered all the above information from various sources about getting rid of smells in silicone cooking utensils, by the way).

    For me, the offending juice flavor was a Rum, Coke, Lime flavor. Yes, it tasted just like the drink and it was quite tasty, for awhile. But the acidity of the flavors imparted the flavor into the gaskets.

    By the way, there are a total of 3 gaskets in the Atlantis: The upper gasket, the lower base gasket, AND a tiny O-ring gasket inside the chimney (to seal the coil). The O-ring in the chimney was the most stubborn to get clean, hence the ultrasonic cleaner.
© 2017 Powered by Aspire