Brand new nautilus tasting burnt

I just purchased my first aspire nautilus this evening. I get home excited to try it out. I fill it up, prep it and take that first puff and it tastes disgusting!!!! The worst burning taste I've ever had with any tank! I'm using it with the eleaf iStick and I have it set to the lowest setting (3.0v 4.7w). When I change the voltage or wattage the burning gets worse. Needless to say I'm very disappointed and looking for a solution as I have wasted $40 on this take and cannot return it. The juice has been sitting in the tank now for nearly an hour with no change to the burning taste at all!
Comments
  • 5 Comments sorted by Votes Date Added
  • Dear Customer,
    Thank you for supporting aspire!
    First,please check the security code of your product on our website,when you check it,it should be original,no one check the security code before you.
    Second,after refilling,customer need to let the tank sit for awhile, to allow the coil to soak up the liquid, some people add some liquid to the coil before installing. After it sits for a little bit, you should take a few pulls, or dry hits. What you do is take a hit, but do not press the battery button. This pulls the liquid into the coil.
    What's more,please use less sweet/sugar/nicotine e-juice.

    Have a nice day!
  • I have the istick battery and the nautilus mini. I was using a Java liquid. I was getting the burnt taste within one day (after 5 ml) approx.. I changed out my atomizer and everything was back to normal... I was able to go through a 5 pack of the atomizers in less than a week. Went to the store I got my new parts from, they tested the batter, tank etch and could not find the issue. I was told it was the liquid (dark and higher Veg ). so I went to a different liquid (light and not Veg). Before the end of the 2nd day I got the burnt flavor again. Went back to the store, the replaced the nautilus tank. I am now once again having the same issue. I have a clear liquid and I have already changed out that atomizers.
    For EACH atomizer I am only getting at MOST 10ml of liquid.
    I am following the process and putting liquid in to let it soak, drawing on it to prime etch, the volts are low and slowly incriminating as I use it. I have it on the smallest air hole.
    I am not sure what is going on with my setup. It is frustrating and when I was using the cheaper tanks, I had none of these issues.

    Any ideas on what is going on? The burnt taste is horrible!
  • this is usually due to "DRY BURNING" the coils, I have done this even though I was warned not to. Before giving up change out the coil with a new one and before you "BURN" a hit you must "DRY HIT" or draw on the tank to "PRIME" it. pulling juice into the coils will prevent the coils from burning up and producing that gawd awful taste.
    do this for a few seconds or until you hear a "GURGLING" sound.
    good luck!
  • I caved, and now I put new coils in right before going to bed, and let things sit overnight in the upright position (Nautilus and Atlantis).

    I hate to say it, but it really makes a HUGE difference. I haven't gotten a pop, spit, or gurgle on my Nautilus's since. They function perfectly now. A nice and quiet hissing sound when firing the coil. Good vapor production. The flavor as even improved by doing this. Never a dry, burnt hit. I can even lay them on their side for extended periods of time and not have any juice weep anywhere.

    It's the same for the Atlantis, but I still get some popping sometimes on a fresh battery.

    Why this is working? I have no clue. But it does.

    Fortunately I have enough units sitting around that when a coil final dies in one unit, I can use another, till bedtime and then change the coil in the dead unit then.

    bbop904,
    You might want to try a larger opening on the air flow ring. The smallest may not allow enough air flow to help "cool" the coil to prevent caramelization of your juice. Personally I use the largest opening (I kind of wish it was a bit bigger) on my Nautilus's.
© 2017 Powered by Aspire