ATLANTIS - NO FLAVOR ON COILS AFTER COUPLE DAYS

I have recently purchased an Atlantis and have enjoyed it, except after a couple of days the coils run out of flavor. I have primed them correctly - filled atlantis, flip over let soak (I have let it soak for hours) and do primer puffs. I have also tried the other way of dripping a little bit of juice down on wicking material and then repeating steps above and letting soak at least one hour. I am now on my 3rd coil in a little over a week. Can you please tell me why/what is making this happen? I never let the Atlantis run dry and I am not using a very thick juice. On my Aspire Nautilus and Nautilus MINI, after a few months they stopped wicking. When the Atlantis is working on a new coil (after the initial floral taste), it is great. But literally, two days later each coil I have tried has gotten a weird taste. This is new juice so I know I'm not just having vapors tongue.
Comments
  • 12 Comments sorted by Votes Date Added
  • I'm having a similar issue now too. I've been with Aspire since I started vaping about 3 months ago and haven't had a complaint. The Atlantis was KILLER right out of the box, it hit well, had great flavor and the coil lasted so long. The second coil (my spare from the box) worked for 2 days then burnt out and the flavor was muted the whole time.

    Currently I am about to try the FOURTH coil from a 5 pack I bought just a few days ago. The first three coils all burnt out immediately upon firing and I also have been using the "correct" methods to prime everything. I just looked inside this coil after about 15 minutes plus a bunch of primer puffs and it doesn't look very saturated with juice.

    edit - this coil is hitting just fine but the flavor just isn't there. I'm getting fantastic flavor at the same moment from my mini Nautilus though.
  • What are you using for battery ? A CF Mod/SubOhm or another one ?
    At what power Wattage ?
    Is it charged well enough ?
  • For me it's the SubOhm battery and it still lacks flavor even if fully charged. The flavor is there but is just very mild compared.
  • The Atlantis will give you other flavours than a Nautilus for example.
    With the Snake Oil, the Nautilus with give a dominant freshness as the Atlantis will reveal the citrus flavours.
    Try with other liquids with more VG.
    What kind of liquids did you guys try on the Atlantis ?
  • I purchased the CF SUBOHM battery and have only used the Atlantis with it. Literally, after 2 days each coil goes bad and gets burnt. I've tried 30%VG/70%PG, 50/50, 70/30 and all have done the same thing. I've gone through 6 coils now. This is ridiculous and it's the 3rd aspire product I've had with issues.
  • I've been using fruit flavors in my Atlantis and dessert flavors in my mini Nautilus trying to avoid "vaper's tongue" and that seeems to be working. Different ratios as I haven't found one that works the "best" ... I also saw on this Aspire support site in another thread that the Atlantis can go up to max 100% VG.
  • I have to ask, where have you gotten your coils from?

    I've still on my first 5 pack of coils which I got directly from Aspire all have been great. My problem is that I forget to keep an eye on the tank and end up dry burning the coils, Do'h!!
  • My coils are coming from where I work. We're not an official reseller but we carry authentics, every piece I have bought and checked the serial # from has been legit (my Premium Kit, CF Sub Ohm, Atlantis and coils).
  • Guz" said:
    I have to ask, where have you gotten your coils from?

    I've still on my first 5 pack of coils which I got directly from Aspire all have been great. My problem is that I forget to keep an eye on the tank and end up dry burning the coils, Do'h!!
    All of my coils are Aspire certified. I'm getting them from local official reseller.
  • My first two coils lasted a long time but I've noticed this pack of replacement coils seem to have a kink or defect in the coil wire. I checked the spot again when I was refilling for the first time on the new coil and can see the wire has the burnt or caramelized (black) up to that spot on the coil. When I pulled the burnt coils apart the first layer of cotton was burnt right through, I'm guessing now that its a hotspot or something making them burn up fast. I'm not sure what exactly it is with the coil wire, on the burnt coils it almost looks like the kink or defect has a tiny bubble on the wire.
    I'm using a mechanical mod, 50/50 pg/vg.

    Does anyone know how to add pictures?
  • The coils are 2 different wires welded if you dismantled it you would notice the ends are soft and the middle is hard try grabbing the ends and pulling apart only the middle gets hot
© 2017 Powered by Aspire