Problem with Nautilus Mini - Burnt Taste

Hi all,

First time poster here.

I was wondering if anyone can help me. I recently purchased a Nautilus Mini to use with my Tesla APV. The tank has a resistance of ~1.7Ω, and I've set my vape to 3.7 volts. The problem I'm having is that after one refill I started experiencing a horrible burning taste that rendered the system effectively useless because it was so bad. I figured I must have been unlucky and received a faulty atomizer, so I replaced the one in the tank with the extra that came with it. However, after a couple of refills it began doing it again. Not only this, but the tank also seems to become somewhat hot. It is still fine to touch, but my friend who also has the exact same system as I has no problems what so ever with burning taste or the tank feeling 'hot'. This has led me to think I have been unlucky and basically have a dud.

Has anyone else experienced this problem? Am I missing something here? I'm pretty upset considering the price I paid.

TL;DR - My Nautilus Mini gives me a horrible burning taste and seems to overheat.

Thanks for any help in advance!
Comments
  • 4 Comments sorted by Votes Date Added
  • You have to prime the new coils. I install mine and do about 6 long mock draws without putting the tank on the mod. It pulls juice into the coil and keeps it from burning.
  • akguy1947" said:
    You have to prime the new coils. I install mine and do about 6 long mock draws without putting the tank on the mod. It pulls juice into the coil and keeps it from burning.
    Doing this does not help. After a couple of hits the burning comes back. I feel as though it shouldn't be doing this on such a low voltage. Any other suggestions?
  • Try with a new coil you bought separately (pack of 5).
    Are these BVC or BDC.
    Buy the BVC, they are better.

    Liquid used ?
    Tried your Mini on another battery or mod ?
© 2017 Powered by Aspire