defective Apsire Nautilus

Hello,

I recently purchased the Aspire Nautilus from a local vapor shop in my area. At first, the Nautilus performed very well and I found myself a happy customer. Unfortunately, this time of bliss would soon come to an end. My Aspire no longer produces the tasty vapor that I had briefly experienced at first purchase. It is all but useless at this point. I have verified that the Nautilus is in fact an authentic Aspire Nautilus. I have done everything in my power to remedy the situation; I have dumped 40 dollars into 2 new packs of Aspire confirmed 1.6 ohm and 1.8 ohm coils. I have purchased differing vg/pg ratio juices, cleaned correctly, and isolated every possible variable in the hope of fixing my Aspire Nautilus with no avail. I have called the vapor store of my original purchase, but they simply point their finger towards Nautilus and claim “all purchases are final”. I find myself quite lost as a customer of Aspire, due to all the great reviews of your product I do not understand why my model fails to work. If there is anything that can be done about this, it would be greatly appreciated. I will shout from the rooftops, declaring Aspires great customer service to the world abound!

Thank you for your time,

Brandon
Comments
  • 6 Comments sorted by Votes Date Added
  • Good day,

    I have a Aspire Nautius mini clearomiser tank and I am trying to determine if this issue I have is a manufacturer's defect. The distributor in the US is willing to change the tank if this is the case, but they are not able to troubleshoot the issue in detail. Hence my reason for coming to you.

    I have checked the information you sent over. Here are my responses.
    The coil is screwed to the base tightly (not over tight).
    The connector pin is a little pop out.
    I have tried the tank with another variable voltage battery which was fully charged, Vision Spinner VV eGo Battery 1300mAh, and it still does not work, however, I have an Aspire CE5-S clearomizer tank and this one is working with the two batteries I have ( Vision Spinner VV eGo Battery 1300mAh and Aspire CF VV - Carbon BattType = 650mAh-Black Fibre)
    The resistance of the first coil was 1.6 ohm; I have used the voltage from 4.2V when I changed the coil to the 1.8 ohm coil.
    Based on the information I provided. Please confirm if this a manufacturer's error?

    Summary of information:
    E-juice used: 50% PG:VG, 18mg nicotine
    Voltage: 3.8V for 1.6 ohm coil and 4.2 for 1.8 ohm coil
    Battery used: Both batteries used were working before - Vision Spinner VV eGo Battery 1300mAh and Aspire CF VV - Carbon BattType = 650mAh-Black Fibre
    Period of using tank: 2 weeks
  • browe18650730" said:
    Hello,

    I recently purchased the Aspire Nautilus from a local vapor shop in my area. At first, the Nautilus performed very well and I found myself a happy customer. Unfortunately, this time of bliss would soon come to an end. My Aspire no longer produces the tasty vapor that I had briefly experienced at first purchase. It is all but useless at this point. I have verified that the Nautilus is in fact an authentic Aspire Nautilus. I have done everything in my power to remedy the situation; I have dumped 40 dollars into 2 new packs of Aspire confirmed 1.6 ohm and 1.8 ohm coils. I have purchased differing vg/pg ratio juices, cleaned correctly, and isolated every possible variable in the hope of fixing my Aspire Nautilus with no avail. I have called the vapor store of my original purchase, but they simply point their finger towards Nautilus and claim “all purchases are final”. I find myself quite lost as a customer of Aspire, due to all the great reviews of your product I do not understand why my model fails to work. If there is anything that can be done about this, it would be greatly appreciated. I will shout from the rooftops, declaring Aspires great customer service to the world abound!

    Thank you for your time,

    Brandon
    Is it working and just not producing good taste?
  • acwarner123" said:
    Good day,

    I have a Aspire Nautius mini clearomiser tank and I am trying to determine if this issue I have is a manufacturer's defect. The distributor in the US is willing to change the tank if this is the case, but they are not able to troubleshoot the issue in detail. Hence my reason for coming to you.

    I have checked the information you sent over. Here are my responses.
    The coil is screwed to the base tightly (not over tight).
    The connector pin is a little pop out.
    I have tried the tank with another variable voltage battery which was fully charged, Vision Spinner VV eGo Battery 1300mAh, and it still does not work, however, I have an Aspire CE5-S clearomizer tank and this one is working with the two batteries I have ( Vision Spinner VV eGo Battery 1300mAh and Aspire CF VV - Carbon BattType = 650mAh-Black Fibre)
    The resistance of the first coil was 1.6 ohm; I have used the voltage from 4.2V when I changed the coil to the 1.8 ohm coil.
    Based on the information I provided. Please confirm if this a manufacturer's error?

    Summary of information:
    E-juice used: 50% PG:VG, 18mg nicotine
    Voltage: 3.8V for 1.6 ohm coil and 4.2 for 1.8 ohm coil
    Battery used: Both batteries used were working before - Vision Spinner VV eGo Battery 1300mAh and Aspire CF VV - Carbon BattType = 650mAh-Black Fibre
    Period of using tank: 2 weeks
    Have you checked the authenticity sticker on the Nautilus coils? It sounds like a problem with the coils if the pin at the base of the 510 is making connection.
  • Having the exact same issues, posting for updates. My first 3 days were great but have since replaced the coils daily and at times hourly trying to figure out the issue. Verified tank and 1.8 coils, with 50/50 juices on an itaste mvp 9 @ watts. The brick and mortar retailer has been working with me to figure out the problem whether it be coils or tank but again as he stated above -the sale is final and they will not take it back.
  • Hello,

    My first time using the Nautilus tank was awesome! I got good clean flavor with a lot of vapor as well. After the tank reached under 2ml of juice I refilled it back to 5ml with a 50/50 vg/pg juice and the taste and vapor production decreased tremendously. I run it with a vision spinner 2 1600mah battery with a 1.8ohm coil. Both the nautilus tank and coils check out as authentic from Aspire. I have bought many coils and liquid trying to figure out why this is happening. I've also taken my Nautilus apart and checked the seals, Pyrex glass, threads, top hardware and bottom hardware for cracks or any damage and nothing meets the eye. I'm not sure what this problem is, I would like to know so I can pay to get this fixed or if it's a defective tank I would like to get a replacement. I was very happy when I first got it and used it for the first time I couldn't ask for a better tank. But it quickly changed it's behavior and I cannot figure out why this is. Please help, it would be greatly appreciated!!

    Thank you for your time,
    Matt
© 2017 Powered by Aspire