Screen glitching - full battery always on - plato

I left my plato plugged in to charge over night, like I have every night for the past 8 months. Now the screen is stuck with the full battery symbol on it. I have tried plugging and unplugging it and removing the battery, no changes. When I hit the fire button the normal display (watts, battery life, etc) comes up, but as soon as I let go the full battery symbol comes back. I have no clue how to fix this and any internet searches have come up blank. Help!
17742415_1329632163797196_1810923856_n.jpg
405 x 720 - 23K
Comments
  • 11 Comments sorted by Votes Date Added
  • You only have one battery cell ? Have you tried with another one ?
    I think that after 8 months, your cell might just be dead, especially if you don't charge it with an external charger but always with the USB ...
  • @Cegoca The battery life is not effected. It's not an issue with the battery itself it still functions fine and hits fine. I believe it's something to do with the screen itself or software.
  • Before saying it's the screen or the firmware (tried an update yet ?), we much be certain it is not your battery cell, ok ?
    So I understand you have been using the same single cell for 8 months in your Plato, correct ?
    That cell has always been charged through the usb cable, am I correct qagain ?

    What is the brand of your cell and it's specifications ?
  • @Cegoca Yes same battery for 8 months and always usb charged. It is an Aspire 2500mAh battery 3.7v li-ion, high discharge 20A/40A
  • @llunatic

    the only way to rule out the battery as the problem is to try a different battery as @Cegoca had asked you. If the results are the same with a different battery, then it's not a battery problem.
  • @charlzrocks I'm an not in a place financially where I can afford to buy a new battery on a "maybe it's the problem" basis, sadly. If I knew for certain then yes.
  • Well now it's not a battery symbol. The screen shows the watts, etc, like it normally does. But instead of turning off after a few seconds it constantly stays on.
  • Hi,
    I have my plato since 4 month and use the original battery and a Panasonic Akku NCR18650B 3,7V 3400mAh and have the same effect since two days.
    Sometime it also doesn't work, only if I press the fire button and one of the two other buttons at the same time it works.
    At the moment shows the display the normal values but with a flash effect. :(

    Very interesting
  • What coil are you vaping on and at what Power Wattage ?
    What's your Plato's firmware version ?
  • @Cegoca Nautilus BVC 1.8 ohm, i have the latest firmware. Usually run it around 15 watts
  • I use the 1.8 Ohm coils with v05 Firmware.
    Since my last post some days, the plato works very well but the most days it works only I press the fire button and one of the other buttons.
    Some days I see every time the full battery symbol, some days the screen does flashing.

    And I have no idea why it does these. :(
© 2017 Powered by Aspire